Back to overview
Degraded

Issue with accessing Fuelsoft and CRM for some customers

May 09 at 08:38am BST
Affected services
180 - Virtual Desktop Core Service

Resolved
May 09 at 08:49am BST

This issue has now been resolved.

Created
May 09 at 08:38am BST

We are aware of some customers reporting not being able to access Fuelsoft or CRM. We are investigating these issues as a critical.