Back to overview
Issue with Icon's not appearing on remote desktop
Apr 24 at 09:58am BST
Affected services
180 - Virtual Desktop Core Service
Resolved
Apr 24 at 09:58am BST
Issue with Icon's not appearing on remote desktop, If you have this problem please give us a ring or sign out and back into the remote desktop.
Affected services
180 - Virtual Desktop Core Service